Samba baru saja merilis versi baru dari perangkat lunak jaringan mereka untuk memperbaiki dua kerentanan kritis yang memungkinkan penyerang yang tidak berkepentingan melakukan serangan DoS dan reset password pengguna lainnya, termasuk akun admin.

Kerentanan denial of service, CVE-2018-1050, mempengaruhi semua versi Samba dari 4.0.0 dan seterusnya serta dapat dieksploitasi “ketika layanan RPC spoolss dikonfigurasi untuk dijalankan sebagai daemon eksternal.”

Hilangnya masukan sanitasi pada beberapa parameter masukan ke panggilan RPC spoolss dapat menyebabkan layanan print spooler macet. Jika layanan RPC spoolss dibiarkan secara default sebagai layanan internal, semua klien dapat merusak koneksi autentikasinya sendiri.” menurut advisory Samba.

Kerentanan kedua, CVE-2018-1057, memungkinkan pengguna terotentikasi untuk mengubah password pengguna lainnya, termasuk pengguna admin, melalui LDAP.

Kerentanan reset password ada di semua versi Samba dari 4.0.0 dan seterusnya, namun hanya berfungsi dalam implementasi Active Directory DC Samba, karena tidak benar memvalidasi perizinan pengguna saat mereka meminta untuk mengubah password atas LDAP.

Sejumlah besar server mungkin berisiko, karena Samba terdapat dalam berbagai distribusi Linux.

Samba telah menangani kedua kerentanan tersebut dengan merilis Samba versi baru 4.7.6, 4.6.14, 4.5.16 dan telah menyarankan administrator untuk segera mengupdate server yang rentan.


Like it? Share with your friends!

Muhammad Zaky Zulfiqor

I just simple person who like photography, videography, code, and cyber security enthusiast.

Comments

error: Content is protected !!